Jump to content
Sign in to follow this  
Aphex

Waiting to spawn grenades

Recommended Posts

Im trying to add to my gear script a command that will wait 2 minutes before spawning grenades in order to prevent fragging on mission start. Anyone know how I could do this?

Share this post


Link to post

If you put a smoke grenade,chem light or anything else like that before the frag grenade in the gear script, that'll be thrown first. This might not be the best way put it'll work in case you can't find another way. Also, you could try using the safe start from one of AC 337's missions but you'll have to talk to him about that one. 

Share this post


Link to post

[_unit] spawn {
_unit = _this select 0;
sleep 120;
(vestContainer _unit) addMagazineCargoGlobal ["HandGrenade",2];// frag grenade
};

Share this post


Link to post

As something like 90% of our missions are using Olsen framework, will I go out on a limp and assume that you use the framework.

 

Olsen Framework is packed full of modules, one of them "anti_nd" helps with the problem of NDs. both with weapon and grenades.

 

You can find the module under missionroot\modules\anti_nd

It contains a settings.sqf where you can change different settings for the module.

 

To activate the module, you just have to add this line: #include "anti_nd\root.sqf" - To the file: missionroot\modules\modules.sqf

 

(remember to always use the newest version of the framework)

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...